Are you a spammer

Please note, that the first 3 posts you make, will need to be approved by a forum Administrator or Moderator before they are publicly viewable.
Each application to join this forum is checked at the Stop Forum Spam website. If the email or IP address appears there when checked, you will not be allowed to join this forum.
If you get past this check and post spam on this forum, your posts will be immediately deleted and your account inactivated.You will then be banned and your IP will be submitted to your ISP, notifying them of your spamming. So your spam links will only be seen for an hour or two at most. In other words, don't waste your time and ours.

This forum is for the use and enjoyment of the members and visitors looking to learn about and share information regarding the topics listed. It is not a free-for-all advertising venue. Your time would be better spent pursuing legitimate avenues of promoting your websites.

Networking on Toshiba Satellite P505D

Any and all things Laptop related.


Networking on Toshiba Satellite P505D

Postby northd_tech » Tue Oct 27, 2009 7:03 am

I've installed both UU 2.3 and 2.2 in both the 32-bit and 64-bit flavors (AMD duo-core CPUs). I had a lot of trouble with both the NIC and the WiFi interface. I was unable to get them working under 64-bit UU 2.3 (but I was able to get them working again under the 32-bit version of UU2.3.

After doing a bunch of "ndiswrapper" compiling/installation, I was able to run the Update Manager (which went out and grabbed a few newer kernels (2.6.28-14, 2.6.28-15, and "2.6.28-16" is the newest. The Atheros NIC just started working with this "2.6.28-16" kernel after a reboot, so support must have been added for that Atheros Interface in the newest kernel- problem solved, I guess (but I didn't fix it).

The Realtek 8192E WiFi still needed "ndiswrapper" installed, and I could never get the 64-bit WiFi driver to work- it said it was installed (and the driver installed), but I could never see "wlan0" interface. I recall the system freezing a few times with the 64-bit driver and 64-bit UU 2.3.

Here is a snippet of hardware diagnostic on that Realtek WiFi interface:
-----------------------------------------------------------------------
118: udi = '/org/freedesktop/Hal/devices/pci_10ec_8192'
info.udi = '/org/freedesktop/Hal/devices/pci_10ec_8192'
info.linux.driver = 'ndiswrapper'

linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:04.0/0000:02:00.0'
info.parent = '/org/freedesktop/Hal/devices/pci_1022_9604'
pci.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:04.0/0000:02:00.0'
pci.product_id = 33170 (0x8192)
pci.vendor_id = 4332 (0x10ec)
pci.subsys_product_id = 33153 (0x8181)
pci.subsys_vendor_id = 4332 (0x10ec)
pci.device_class = 2 (0x2)
pci.device_subclass = 128 (0x80)
pci.device_protocol = 0 (0x0)
pci.vendor = 'Realtek Semiconductor Co., Ltd.'
info.vendor = 'Realtek Semiconductor Co., Ltd.'
info.subsystem = 'pci'
info.product = 'Unknown (0x8192)'
pci.subsys_vendor = 'Realtek Semiconductor Co., Ltd.'
linux.hotplug_type = 2 (0x2)
linux.subsystem = 'pci'
--------------------------------------------------
My notes page didn't have "Atheros" in a search just now, but there is a "driver" available from Atheros here for the 81xx family:

http://www.chipdrivers.com/download-get/786/191/36/

http://www.chipdrivers.com/chipset/netw ... 132/linux/

Unfortunately, I never got that to build or install- there were several errors about function calls IIRC. This Atheros AR8132 Ethernet does appear to work in this newer kernel "2.6.28-16" only though.

Actually, it looks like the Ethernet is showing up as "Attansic" rather than "Atheros"
-----------------------------------------------------------
15: PCI 400.0: 0200 Ethernet controller
[Created at pci.314]
UDI: /org/freedesktop/Hal/devices/pci_1969_1062
Unique ID: YmUS.xQq8Ov29x34
Parent ID: H0_h.AQdh0Ungjl1
SysFS ID: /devices/pci0000:00/0000:00:06.0/0000:04:00.0
SysFS BusID: 0000:04:00.0
Hardware Class: network
Model: "Attansic Ethernet controller"
Vendor: pci 0x1969 "Attansic Technology Corp."
Device: pci 0x1062
SubVendor: pci 0x1179 "Toshiba America Info Systems"
SubDevice: pci 0xff50
Revision: 0xc0
Memory Range: 0xf0300000-0xf033ffff (rw,non-prefetchable)
I/O Ports: 0xb000-0xbfff (rw)
IRQ: 5 (no events)
Module Alias: "pci:v00001969d00001062sv00001179sd0000FF50bc02sc00i00"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #37 (PCI bridge)
-----------------------------------------------------------------------------------
Other than the Ethernet and the WiFi problems, this Toshiba laptop works quite well with UU 2.3- sound and video worked quite well. The 2.6.28-15 kernel did seem a little "buggy" though, and I had the most trouble with that one. 2.6.28-14 was much better (but I couldn't get the Atheros AR8132 ethernet to work with that one either).
northd_tech
U.E. Newbie
U.E. Newbie
 
Posts: 2
Joined: Tue Oct 27, 2009 6:13 am
Operating System: Ultimate Edition 3.1 64 BIT



Re: Networking on Toshiba Satellite P505D

Postby Admin-Amir » Tue Oct 27, 2009 7:46 am

Hello northd_tech .

Try this post here :
http://www.datanorth.net/~cuervo/blog/r ... d-patches/
Admin-Amir
 


Return to Laptops-All topics

Who is online

Users browsing this forum: No registered users and 2 guests

cron